Frequently Asked Questions

Does IWB Pro/DigiClass run on Windows XP?
Last Updated 3 years ago

The minimum OS requirement for the Windows versions of IWB Pro and DigiClass is Windows 7 Professional.

Although we have had reports of customers running these applications on XP, we do not support it, and there are likely to be some features that will not work on XP.

Windows XP is no longer supported by Microsoft.

Please Wait!

Please wait... it will take a second!